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Basic Web Page Authoring with Dreamweaver

Macromedia Dreamweaver is a sophisticated graphical HTML editor for the creation of professional-quality Web
pages.  Dreamweaver can be used to author a single Web page or to create and manage a multi-page site.  The
software allows the user to modify his or her work using a graphical WYSIWYG (What You See Is What You Get)
interface while simultaneously viewing and editing the HTML source code.

This handout will walk you through the process of creating a single Web page, including:

Palettes and Windows p. 1

Changing Program Preferences p. 1

Page Properties
Page Title p. 2
Background Image/Color p. 2
Text Color p. 2
Link Colors p. 3

Name and Save File p. 3

Preview in Web Browser p. 3

Add Text p. 4
Line Breaks p. 4
Format Text

Size p. 4
Color p. 4
Font p. 5
Alignment p. 5
Style p. 5
Spelling p. 5

Lists p. 5

Links p. 6

Named Anchors p. 7

Horizontal Rules p. 8

Images
Inserting p. 9
Resizing p. 9
Alignment p. 10
Alternate Text p. 10
Image Borders p. 10
Horizontal and Vertical Space p. 10
Links p. 10

Tables
Inserting p. 11
Table Properties p. 11
Background Color/Image p. 12
Border Color p. 12
Merge and Split Cells p. 12
Cell Width p. 12

View HTML Code p. 12
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Getting Started – Palettes and Windows

1. Double-click the desktop icon to open the Dreamweaver program.

2. Several windows open.  These are the three we will use today:

If your Objects and Properties windows are not open, select Window>Objects or Window>Properties from
the Menu.  A checkmark to the left of the window name indicates that it is open.

3. Changing program preferences affects the appearance of the Objects palette and the Status bar in the
Document window.

Select Edit>Preferences from the menu to
open the Preferences dialog box.

With the General category selected, you
can set the Objects palette to display icons
and text; customize the extension to be
added to filenames (.htm or .html); and set
the number of History steps (levels of undo),
among other things.

With the Status Bar category selected, set
the connection speed most likely used by
your audience.  This will customize the
download status information in the Status
bar and tailor it to your users.

The Properties
inspector contains all
of the tools you will
need to format text,
images, tables, etc.
Format options
change depending on
the currently selected
object.

The Objects
palette allows the
user to insert a
number of
objects, such as
images, tables,
horizontal rules,
layers, applets,
and Flash and
Shockwave
movies.

Menu bar

Status bar

Title bar

Tag selector Window size

Download status

Launcher

The Document window
contains the large, blank
window in which you will
create your Web page.
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Page Properties

Begin by setting the page properties. These are global properties that remain constant throughout the entire page
(but not throughout the site).  Select Modify>Page Properties from the Menu.  The Page Properties dialog box
appears.
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This title will appear in
the title bar at the top of
the browser window.

If desired, select an
image to tile and fill the
background of the page.
Select a solid color for
the page background
and default colors for
text and links.
odified: 02/01/2001  athwaits Copyright Arizona Board of Regents, 2000.
me: dw3intro.doc The University of Arizona Library

2

n the blank title field, type a title to appear in the title bar at the top of the browser window.

age titles can contain several words separated by spaces.  Any combination of letters, numbers, and
unctuation is appropriate.  This is not always the case when working with Web pages – spaces and
unctuation can not be used in the naming of images and HTML files.

he background of the Web page can be filled with a solid color or an image.  Background images are usually
mall (no more than 200x200 pixels) images that tile to fill the entire browser window.  Background images
hould be used sparingly, as they easily overwhelm the rest of the page and make text difficult to read.  Most
rofessional Web pages have solid-colored backgrounds, perhaps with a patterned bar down one side of the
creen.

elect a background color by clicking on the small gray box next to the word “Background.”

he Colors palette pops up.  Use the eyedropper tool to
elect a color (note: many of the colors are repeated).
lick Apply to preview the background color in the
ocument Window.  Test different colors until you find
ne you like.

se the color palette to select a text color for the page.  Text will appear in this color as it is typed, but color
pplied to individual characters, words, or sentences overrides this setting.  If no color is specified the text will
e black.

This hex code represents
the selected color
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4. Click in the appropriate color swatches to choose colors for text that appears as links, visited links, and active
links.

• A link is a character, word, or line of text that is clicked to take the user to another page.  Links
customarily differ in color from other text and are underlined, showing users where they should click to
navigate a page.  The default color for links is blue.

• A visited link is a link to a page that was recently visited by the user.  Links usually change color after they
are visited to show users where they have and have not been.  The default color for visited links is purple,
and such links often stay purple for several days, even if the Web browser and/or computer are shut
down and restarted.  The amount of time that visited links remain purple (or whatever color you choose)
depends on settings within the user's Web browser.

• An active link is a link that is being clicked.  Active link colors often escape notice because they are
displayed only while the mouse button is depressed, creating a flash of color.  The default color for active
links is red.

5. Page properties can be previewed at any time while the dialog box is open – simply click the Apply button.
Once you are satisfied with your color choices, click OK.  Page properties can be modified at any time if the
dialog box is reopened.

Save and Preview
1. Name and save the file.  It is important to save early when working in Dreamweaver to create document-

relative paths for links and images that will be added later.  Document-relative paths ensure that the images
will display in the page and the links will work correctly once you transfer your page to a Web server.  If you
insert images in the page before it has been saved the first time,  a pop-up box will warn you that you need to
save the file.

a) Select File>Save from the Menu.  The
Save As dialog box appears.

b) Choose a directory in which to save your
file.  Remember that an HTML document
should be saved in the same directory with
its associated image files.

c) Name your file.  There should be no
spaces in your file name.

d) The correct file extension will be added to
the filename.

e) Click Save.  Continue to save often as you
work on your page.

2. Preview your work in a Web browser by pressing the F12 key or selecting File>Preview in
Browser>Netscape from the Menu.  This will launch Netscape.  You can preview in a browser at any time
while working in Dreamweaver.  Close the browser window when you are finished.

It is a good idea to preview your page in a browser before posting it to a Web server, as this is the only way to
test links and other interactive features such as JavaScript rollovers.
WARNING: Sometimes, after previewing your page in a Web browser, Dreamweaver displays a pop-up
window warning that your page has been modified in another program and asking if you would like to save
changes.  Say NO – if you don’t, you will lose all of the changes made since the last save.
modified: 02/01/2001  athwaits Copyright Arizona Board of Regents, 2000.
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Text

To create text in Dreamweaver, position the cursor in the Document window where you would like the text to
begin and start typing.  Formatting is applied to text after it is typed.  At the end of a line, the text will wrap to the
next line.  Text in Web pages wraps to fit the width of the browser window.

If you do not want text to wrap, insert manual line breaks or paragraph breaks.

• Press Shift-Enter or click the Insert Line Break icon (in the Objects palette) to insert a single line
break.  This creates the equivalent of single-spaced text.

• Press Enter to insert a paragraph break (this adds a blank line between lines of text, similar to double-
spacing).

Text appears in size 3 Times New Roman font, the default font face and size for the World Wide Web.  The
options in the Properties inspector are used to format text (the same options can be accessed by choosing Text
from the menu).  Highlight (select) the text to be modified and change any of the properties:

1. Make the text larger.  Select a number from the Text Size pull-down menu.

If desired, assign a size relative to the basefont (default) size of 3 by selecting + or – 1
through + or – 7.  This method is not recommended – it is best to stick to font sizes of 1 –

2. Click in the Text Color box and select a color from the Colors palette.

This color overrides the global text and link colors set in the Page Properties dialog box.

Choose paragraph,
heading, or
preformatted style

Font Combination:
Select font face

Text color Bold

ItalicHex code
t

Hyperlink: type the target
URL in this box

Point to file

Browse for file

Target frame in which linked page should load

Unordered list

Ordered list Text outdent

Text indent
Help
Text
size
Align Left, Align
Center, Align Righ
Quick Tag Editor
 7.

Expand window to
view more options
A word about text sizes: Dreamweaver specifies text size in the way Web browsers recognize it: as
a number between 1 and 7.  HTML is a very simple programming language, and, as a result,
browsers do not understand common text sizes like “12 point.”  Unfortunately, the sizes 1 to 7 are
completely arbitrary – they do not correspond with point or pixel sizes.  The only way to choose a text
size is to try them all out and see which looks best.
. 4
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3. Choose a font face from the Font Combination pull-down menu.  Browsers display
the first font from the selected group that is installed on the user’s system.

If the font you want to use is not listed, select Edit Font List to create a custom font
list.  Be aware, however, that a user will not see that font unless it is installed on his or
her computer.  Dreamweaver’s pre-set font lists contain the most common fonts – the
ones found on most computer systems, regardless of platform or operating system.

4. Use the alignment icons to select left, center, or right justification for text.
These icons change the alignment of a word, line, or paragraph of text.

5. Click on the Text Indent icon to indent a single line of text or an entire paragraph.  This
simulates the effect of a left page margin.  Indent is handy for offsetting sections of text such
as quotes.  Unfortunately, it is not possible to indent just the first line of a paragraph.

6. Use the Bold and Italics icons to change the text style.

7. Check Spelling: Place the cursor at the top of the Document window and select Text>Check Spelling
from the Menu, or use the keyboard shortcut Shift+F7.

Lists

Text can be arranged into numbered (ordered) or bulleted (unordered) lists.

1. Place the cursor on a new, blank line and click on the Ordered List icon.

2. Type your first list item next to the number 1.

3. Press the Enter key to create number 2 on the next line.  Type the next list item.

4. When you have finished your list, press the Enter key twice.

Change the ordered list to an unordered list:

a) Highlight all of the list items.

b) Click on the Unordered List icon.
The numbers become bullets.

Bullet size and color can not be easily changed.  To change the bullet shape, place the cursor next
to the first item in the list and click on the List Item button in the Properties inspector.

The List Properties dialog box opens.  Click on the Style
pull-down menu to see available styles.

• Bulleted (unordered) lists can have bullet, circle, or
square style.

• Numbered (ordered) lists can have numbers, Roman
numerals (small or large), or alphabet characters (small
or large).
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Links

Text can easily be made into a link to another Web page.  Links can take the user to another page within your
Web site, to a completely separate Web site, or to an e-mail composition window (this will only work if your Web
browser is configured for e-mail).

Link to a Page Within Your Site:

a) Select the word or words that will become a link.

b) Click on the Browse for File icon in the Properties inspector.
The Select HTML File dialog box appears.

c) Browse for the desired .html file.  Click Select.  The selected word/s in the Document window change
color and become underlined to indicate that they are now a link.

d) If you know the name of the file you want to link to, there is no need to browse for it – just type the
filename and extension (ex: page2.html) in the Link field.  Linking to a page in a different folder or
directory requires that the entire path be entered in the Link field (ex: ../homepage/images/pix.html).

Link to a Separate Web Site:

a) Select the word/s that will become the link.

b) Type the URL (address) of the target site in the blank Hyperlink field and press the Enter key.  You
must include the http:// portion of the address, or your links will not work.

Create an E-mail Link:

Method One:
a) Place the cursor where the e-mail link should appear.

b) Click on the Insert E-Mail Link icon in the objects palette.  The Insert E-Mail Link dialog box appears.

c) Enter link text in the Text field.

d) Enter the e-mail address in the E-mail field.

e) Click OK.

Method Two:
a) Select the text that will become the link.

b) Type mailto: in the text field, followed by the desired e-mail address.  Do not include a space after
the colon.  If the address is not preceded by mailto:, Web browsers will not recognize it as an
address.

Links must be previewed in a Web browser – they do not work in the Dreamweaver interface!
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Named Anchors

Long text documents on the Web often have a menu at the top of the page that links to other parts of the same
page.  Named anchors are used to create links to another part of a page or to a particular point in another page.
An anchor is a position placemarker in a document, and attaching a name to that anchor allows the anchor to be
referenced in hyperlinks.

When a link to an anchor is clicked, the Web browser jumps directly to the desired portion of the page, and the
line that contains the anchor is lined up with the top of the browser window. Named anchors are often used to
jump to a specific topic or to the top of a document, quickly taking your visitor to the selected position.

Insert an Anchor:

1. Place the cursor in the page where the anchor should be placed.

2. Select Insert>Named Anchor from the menu.  The
Insert Named Anchor dialog box appears.

3. Type the anchor name in the dialog box.  Anchor
names are subject to the same restrictions as file
names: no punctuation, no spaces, and the text is
case-sensitive.  Click OK.

4. A yellow anchor symbol appears in the Document window. If no symbol is visible, select
View>Invisible Elements from the menu.  This symbol will not be visible when the page is viewed in a
Web browser.

Link to an Anchor:

1. In the Document window, select the text or image from which to link.

2. In the Link field of the Property inspector, type a number sign (#) and the name of the anchor. For
example:

• To link to an anchor named "chapter1" in the current document, type #chapter1.

• To link to an anchor named "chapter1" in a different document in the same folder, type
filename.html#chapter1.

Modify an Anchor:

1. To move an anchor, click and drag it to a new location.

2. To change an anchor name, click on the yellow anchor symbol in the Document window.  Type a new
name in the Properties inspector.

Add a number sign (#)
and the anchor name to
the end of the link
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Horizontal Rules

Horizontal rules provide quick dividers between sections of page content.

1. Place the cursor where you would like the horizontal rule to appear.

2. Click on the Insert Horizontal Rule icon in the Objects palette (or select Insert>Horizontal Rule from
the Menu).

A horizontal rule appears in your document window with the default attributes of 100 percent width, center
alignment, and 3-D shading.  The Properties inspector changes to display the horizontal rule options.

3. Change the width of the horizontal rule in one of two ways:

•••• To set a width relative to the width of the browser window, select % from the W drop-down 
value in the W field.  The horizontal rule will automatically resize depending on the size of t
window.

•••• To set an absolute width, select pixels from the drop-down menu.  Type a value in the W fi
horizontal rule will always be that number of pixels wide, regardless of the width of the brow

4. Change the height of the horizontal rule by typing a value (in pixels) in the H field.  The default h
pixels.

5. Change the alignment by selecting Left or Right from the Align drop-down menu.  The default 
center.

6. Un-check the Shading box.  Notice that the horizontal rule now appears as a solid gray line.  W
checked, the horizontal rule appears embossed or raised.

With shading deselected, it is especially important to preview pages in both Internet Explorer an
Navigator, as the browsers display horizontal rules differently.  Netscape displays unshaded rul
rounded corners, while corners are squared in Internet Explorer.

Repositioning
Objects in the Document window  can easily be moved and arranged.

a) To move text, select the text and choose Edit>Cut from the Menu.  Reposition the cursor w
would like the text to appear and choose Edit>Paste.

b) To move an object such as an image or horizontal rule, click and drag the object to a new lo
Objects can be dragged higher or lower in a page, but not to the right or left.  Use the alignm
change the horizontal positioning of an object.
Help
Select left, center,
or right alignment
Name (optional)
 Height (in pixels)
Width (in pixels or percent)
3-D shading
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Images

Insert an image in the page:

1. Place your cursor where you would like the image to appear.

2. Click on the Insert Image icon in the Objects palette (or select Insert>Image from the Menu).

The Select Image Source dialog box appears.  Browse for the image to insert, then click once on the desired
image.  A preview of the selected image appears in the image preview area.  If you do not see a preview of
the image, select the Preview box at the bottom of the dialog box.

3. Click Select.  The image appears in the document window and the Properties inspector changes to reflect the
appropriate options.

4. Althou
which
appea
image
Makin
The im

•••• 

Select the Preview Images box
to display the preview above.

Image information:
pixel dimensions,
file type, file size,
download time

Browse for the
directory or disk
in which the
image is saved

Because of the
limitations of
Web browsers,
only GIF, JPEG,
and PNG files
can be inserted
in pages.
Name (optional)
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•••• Click and drag one of the handles on the side, corner, or bottom of the image, OR

•••• Resize the image proportionately by clicking and dragging a corner handle while holding down the
Shift key.

•••• If your image becomes distorted or you change your mind about resizing, click on the Refresh button
to return to the original dimensions of the image.

5. Change where the image appears on the page.  Your image can be
left-justified (default), centered, or right-justified.  Warning: the Align
setting in the Properties inspector does not change image
alignment.  It only modifies the alignment of text that appears next to
an image.

To center the image in the Document window, select
Text>Alignment>Center from the Menu, or click on one of the
alignment icons in the lower half of the
Properties inspector.

6. Alternate text is an important addition to any Web page that contains images.  Alt
text is the text label that pops up when the cursor is held over an image without
clicking (see example at right).

Alt text is a nice touch for users who can see your Web page, but it is essential for
those who can not see it.  Users with visual impairments depend on screen reader
software (such as JAWS) to read all of the text and links on Web pages.  Unless
you include an Alt text tag with a description, these users will not know what the
images are and will be unable to navigate images used as links.

Users choose to browse Web pages in a text only format, either to shorten
download times on a home computer or to access the Web via a cellular phone or
Personal Digital Assistant (i.e. Palm Pilot), also benefit from the use of Alt text.

7. Although they are seldom seen on the WWW, images can have borders.  Type a pixel size in the Border field
in the Properties inspector to add a border of that width on all sides of the image.  The drawback: borders will
be one of only two different colors.  Borders around image links will be the link color selected in the Page
Properties dialog box, and all other borders will be the text color set in the Page Properties.

8. Horizontal and Vertical space are minor adjustments that can make a big difference in a Web
page.  Unless empty space is added manually, images, text, and all other objects in a page
will be so close together that they touch.  To make text more readable and keep pages from
looking cluttered, add a few pixels of empty horizontal space (left and right sides) or vertical
space (top and bottom) to an image or table.

9. An image can be a link to another Web page.  The process is very similar to creating a text link:

•••• Type a URL (Web address), .html file name, or e-mail address (including mailto:) in the Link text box,
OR

•••• Use the Browse for File icon to search for a file

10. Place your cursor to the right of an image and type few sentences.  Notice how the first line of text appears on
the same line as the image, and the rest wraps below the image.  If you want to place more than one line of
text next to an image you must use a table for layout.  Read on for more information . . .
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Tables
Tables are a very useful HTML tool.  Two common uses:

•••• A traditional table with cells to display data in an organized fashion

•••• Page layout with tables.  Using tables with invisible borders for Web page layout allows for increased
control over the appearance of a page.  Tables can display images and paragraphs of text side-by-side
and simulate page margins, among other things.

1. Add a table to your document.  Place your cursor in the desired location and click the Insert Table icon
(or select Insert>Table from the menu).  The Insert Table dialog box appears.

2. Select the number of rows and columns you want in your table.  Set the width of the
of these selections can easily be changed later.

Although the Cell Padding and Cell Spacing boxes appear blank, the default value
one pixel each.  To change them to zero (if desired), you must manually type 0 in th

3. Click OK to add the table to you Web page.  The table appears in the document win
inspector changes to display table options. To modify the table at any time, click on 
then change the properties.

4. Table cells can contain text, images, or even other tables.  Place the cursor in an em
image or begin typing.  Images can also be dragged and dropped into table cells.

Cell borders automatically adjust to accommodate an image placed in a cell, but cel
resized manually.  Click and drag cell borders to resize the table cells, or click and d
to change the width of the entire table.

Border color highlight

Border color shadow Background color

Background image

Table name
(optional)

Number of rows

Number of columns

Cell spacing

Cell padding

Height in percent
or pixels

Width in percent or pixels
Number of pixels between
the cell content and the
cell boundary (or wall)
Number of pixels between
each table cell
Width of table in pixels
or percent of browser
window
Number of columns
Number of rows
Width of border in pixels
(0 = invisible borders)
gents, 2000.
izona Library
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5. Tables can contain background colors and images different from the background of the entire page.  Click
the Browse for file icon to search for a background image, or click in the Background Color swatch to select a
background color for the entire table.

6. Border colors are also customizable, but may not display correctly in some Web browsers.  By default, table
borders are gray with highlights on the top and left sides and shadows on the bottom and right sides.

• Shaded borders in various colors are created by specifying Light Border and Dark
Border colors in the Properies inspector.

• For a solid-colored border with no shading, specify a single border color in the lower
right corner of the properties inspector.

7. More table properties are applied to individual cells.  Click inside a table cell to select it and reveal the rest of
the options in the lower half of the Properties inspector.

8. The Merge and Split icons are used to customize tables by creating the precise size and number of cells
needed the achieve the desired layout.

• To merge cells, click and drag (vertically, horizontally, or both) to select two or more adjacent cells, then
click the Merge icon.

• To split cells, place the cursor in the cell to be divided, then click the Split icon.  The Split Cell dialog box
appears.

Select either Rows or Columns in the top portion of the
dialog box, then type the desired number of rows or
columns in the box below.  Click OK.  The cell is
subdivided into several rows or columns without adding
any additional rows or columns to the table.

9. Set a specific width for a cell by typing a number in the width box.  Notice that these numbers appear as
percentages of the total table width.

10. Choose a background color or image for each table cell – a different color in each cell, if desired – by
browsing for a background image or selecting a color from the palette.  Individual cell colors override the
background color set for the entire table.

Merge cells

Split cell

Horizontal and
vertical alignment of
content within cell

Specify width and
height of individual cell

Background image or
color of selected cell

HINT: To view your HTML code at any time, click on the Show HTML Source icon in the lower right
corner of the Document window (in the status bar).  The HTML Source window opens, allowing the
user to edit source code directly and work in both windows simultaneously.
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